Notification - Esendex Service Degradation
Incident Report for Esendex
Resolved
We've completed our immediate investigations and have made a number of changes to our systems; we will shortly be publishing details of an emergency maintenance window this week for further remedial work to be carried out.
We will of course continue to monitor for further occurrences.

Please accept our sincere apologies for any inconvenience caused, and assure you that we take very seriously any incident in which our high standards are not achieved.
Posted Jan 16, 2017 - 15:17 UTC
Update
We are reasonably sure that the recent degradation of service is down to a DDoS, or Distributed Denial of Service attack. We believe the purpose of the attack is to drive customers to a phishing site that appears to be Esendex's login page. We have had contact with several other SMS service providers who are experiencing similar issues.

We are working on several solutions to prevent future attacks, but it's equally important that our customers are aware of the phishing site and only access your account via https://login.esendex.com/. Please do not click on any Google adverts with less familiar domain extensions such as .pw, .me, .top etc.

If you think you or any member of your team may have logged in via the fake site, please change your password immediately. You can do that here: https://login.esendex.com/resetpassword.
Posted Jan 10, 2017 - 16:16 UTC
Monitoring
The unprecedented levels of traffic we were experiencing have subsided and services are now functioning again.
Our operations team are continuing their investigations into the cause and source of this traffic, and are working on a number of measures to prevent further disruption.

We will leave this incident as monitoring until we are confident of stability.
Posted Jan 10, 2017 - 12:22 UTC
Identified
At this time we are seeing an unprecedented high volume of traffic has resulted in temporary disruption of some services. Our Operations team are working with our network service providers to locate the source of this and block it as soon as possible.

We'll keep updating this page as we know more.
Posted Jan 10, 2017 - 11:21 UTC
Investigating
Our monitoring services have detected potential issues with our service.

We are currently investigating these, but you may be experiencing difficulties in accessing our services or your ability to send or receive messages.

Thank you for your continued patience and support, whilst we work with our suppliers to resolve this.

Please direct any queries to our support team at support@esendex.com.
Posted Jan 10, 2017 - 10:44 UTC