Important - phishing alert
Incident Report for Esendex
Resolved
This incident has been resolved.
Posted Jan 03, 2017 - 18:13 UTC
Identified
We've been made aware that a determined and pretty sophisticated fraudster has purchased advertising space on Google, and is masquerading as Esendex. Their advert looks like this:

http://dox4euoyzny9u.cloudfront.net/images/support/fraudster.jpg

Please do *not* click on this link. It is being used to phish for usernames and passwords.

To log into your Esendex account, always use https://login.esendex.com. We're working with Google to get this removed and taking appropriate legal guidance to prevent a recurrence.
Posted Jan 03, 2017 - 18:07 UTC