Investigating - Esendex Service Degradation

Minor incident Rich Messaging Platform Rich Messaging API
2026-02-06 21:15 GMT · 5 days, 18 hours, 39 minutes

Updates

Resolved

We are pleased to confirm that the issues which affected some of our services are now resolved.

We’re sorry that this happened and a full root cause analysis will take place.

February 12, 2026 · 15:54 GMT
Monitoring

Further changes have been implemented on the RCP platform, and these are showing improvements in delivery times. We will monitor the platform overnight and provide a service update in the morning.

We apologize for the disruption and appreciate your continued patience.

February 11, 2026 · 19:41 GMT
Investigating

Following the changes implemented yesterday on the RCP platform, our internal metrics and testing continue to show improvement. However, we are still receiving reports of delays. Our team is investigating these reports and is working urgently toward a solution.

We apologize for the disruption and appreciate your patience while we work toward a full resolution.

February 11, 2026 · 12:50 GMT
Monitoring

Following investigation we have implemented some changes to the RCP platform, our internal metrics and testing show improved performance for send times, we continue to monitor closely.

We apologise for the disruption and appreciate your patience as our team works toward a resolution.

February 10, 2026 · 17:17 GMT
Investigating

We are continuing to review message delivery rates following our initial remediation efforts.

While investigations into the remaining delays are ongoing, our engineering teams remain focused on restoring full service. We will provide further updates as new information becomes available.

February 10, 2026 · 10:46 GMT
Investigating

Investigations into message delivery delays within Rich Messaging are ongoing.

We have implemented some remediation steps and are continuing to review the message delivery rates. We appreciate your continued patience as our team works toward a full resolution.

February 9, 2026 · 15:47 GMT
Investigating

We are continuing to investigate delivery delays within Rich Messaging that are impacting message performance for some customers.

We apologize for the disruption and appreciate your patience as our team works toward a resolution.

February 9, 2026 · 10:56 GMT
Monitoring

We are still seeing some delays to sends via Rich Messaging, while investigating next steps.

February 8, 2026 · 22:15 GMT
Monitoring

We are pleased to confirm that the issues which affected some of our services are now resolved and we are actively monitoring the situation.

February 8, 2026 · 01:25 GMT
Issue

We are currently experiencing some temporary technical issues which may be affecting the delivery time for some of our customers’ messages; in some cases this may also include gaining access to any of our services.

We’re sorry that this is happening. Thank you for your continued patience and support while we work to resolve this.

February 7, 2026 · 09:10 GMT

← Back