SMS Delivery Delays - DE region

Minor incident Customer Portal Esendex SMS Platform REST API SOAP API FormPost API SMPP API Collstream APIs Push Notifications App Notifications Inbound SMS SMS Surveys SMS Chat FTP Voice Platform REST API SOAP API FormPost API Outbound callflows Outbound callblasts Inbound IVR Email Platform Email SMS Echo for Email
2026-03-06 09:55 GMT · 6 hours, 54 minutes

Updates

Resolved

After continued monitoring, we are happy that service has returned to normal with no further delays to message delivery. Thank you for your patience.

March 6, 2026 · 16:17 GMT
Monitoring

We are continuing to track the delays affecting SMS delivery. We are now seeing steady improvement; internal tests are delivering successfully, and delivery reports are starting to arrive expected. We will provide a further update once service is fully restored.

March 6, 2026 · 12:58 GMT
Issue

We are currently investigating reports of delayed SMS delivery for the DE region across our platform. Our upstream provider has confirmed a global issue affecting their network. We are working closely with them to monitor the situation and will provide further updates as more information becomes available.

March 6, 2026 · 09:55 GMT

← Back