Esendex website unavailable
Incident Report for Esendex
Resolved
We are pleased to confirm that the issues which affected the website are now resolved.
Posted Feb 16, 2023 - 08:16 UTC
Identified
We are experiencing intermittent outages on the brochure sites.
Posted Feb 15, 2023 - 14:16 UTC
Investigating
We are currently investigating this issue.

Echo and Support sites are still available.

https://support.esendex.co.uk/sms/introducing-echo/
Posted Feb 15, 2023 - 14:10 UTC