Three UK outage
Incident Report for Esendex
Resolved
This incident has been resolved.
Posted Dec 02, 2023 - 09:57 UTC
Monitoring
We are aware of the current Three UK outage and monitoring closely. You may experience issues sending to Three UK handsets.
Posted Dec 01, 2023 - 16:47 UTC
This incident affected: Customer Portal (Esendex).