Esendex Website Intermittent issues
Incident Report for Esendex
Resolved
This incident has been resolved and will be under close monitoring.
Posted Feb 20, 2023 - 08:35 UTC
Identified
We are currently investigating this issue.

Echo and Support sites are still available.

https://support.esendex.co.uk/sms/introducing-echo/
Posted Feb 17, 2023 - 08:23 UTC